RFR: 8311248: Refactor CodeCache::initialize_heaps to simplify adding new CodeCache segments [v9]

Boris Ulasevich bulasevich at openjdk.org
Wed Apr 3 13:11:29 UTC 2024


On Wed, 3 Apr 2024 05:06:16 GMT, Tobias Hartmann <thartmann at openjdk.org> wrote:

>> Boris Ulasevich has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains ten commits:
>> 
>>  - minor updates according to review comments
>>  - minor update: align_up for ReservedCodeCacheSize
>>  - one another cleanup round
>>  - minor update. removed helper function as it caused many comments in the review
>>  - set_size_of_unset_code_heap
>>  - minor update
>>  - apply suggestions
>>  - cleanup & test udpdate
>>  - 8311248: Refactor CodeCache::initialize_heaps to simplify adding new CodeCache segments
>
> src/hotspot/share/code/codeCache.cpp line 183:
> 
>> 181:   if (size < required_size) {
>> 182:     log_debug(codecache)("Code heap (%s) size " SIZE_FORMAT " below required minimal size " SIZE_FORMAT,
>> 183:                          codeheap, size, required_size);
> 
> Should `size` and `required_size` be printed in `K`?

Yes. Thanks!

> src/hotspot/share/code/codeCache.cpp line 256:
> 
>> 254:   if (total != cache_size && !cache_size_set) {
>> 255:     log_info(codecache)("ReservedCodeCache size %lld changed to total segments size NonNMethod %lld NonProfiled %lld Profiled %lld = %lld",
>> 256:                         (long long) cache_size, (long long) non_nmethod.size, (long long) non_profiled.size,
> 
> Any reason you are using `%lld` here and below instead of `SIZE_FORMAT`?

Right. SIZE_FORMAT is better. Thank you!

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/17244#discussion_r1549708063
PR Review Comment: https://git.openjdk.org/jdk/pull/17244#discussion_r1549705763


More information about the hotspot-dev mailing list