RFR: 8319797: Recursive lightweight locking: Runtime implementation [v15]
Axel Boldt-Christmas
aboldtch at openjdk.org
Fri Jan 26 19:01:32 UTC 2024
On Fri, 26 Jan 2024 16:35:22 GMT, Daniel D. Daugherty <dcubed at openjdk.org> wrote:
>> Axel Boldt-Christmas has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains 50 commits:
>>
>> - Update copyright
>> - Merge remote-tracking branch 'upstream_jdk/master' into JDK-8319797
>> - Add verify calls
>> - Assert valid lock stack offset
>> - Typos, wording and whitespace
>> - Fix miss in is_recursive improvement
>> - Added comment about the rational behind full lock stack inflation. May need rewording
>> - Add logging when lock stack capacity is exceeded.
>> - Remove inaccurate comment
>> - Correct nomenclature balanced vs structured.
>> - ... and 40 more: https://git.openjdk.org/jdk/compare/c313d451...8df7f441
>
> src/hotspot/share/runtime/lockStack.inline.hpp line 43:
>
>> 41: assert(is_aligned(offset, oopSize), "Bad alignment: %u", offset);
>> 42: assert((offset <= end_offset()), "lockstack overflow: offset %d end_offset %d", offset, end_offset());
>> 43: assert((offset >= start_offset()), "lockstack underflow: offset %d end_offset %d", offset, start_offset());
>
> nit typo: s/end_offset/start_offset/
Good. That is a copy-paste-typo. So two typo fixes coming up.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/16606#discussion_r1468035466
More information about the hotspot-dev
mailing list