RFR: 8332900: RISC-V: refactor nativeInst_riscv.cpp and macroAssembler_riscv.cpp [v4]

Robbin Ehn rehn at openjdk.org
Mon Jun 3 11:06:03 UTC 2024


On Fri, 31 May 2024 14:40:15 GMT, Hamlin Li <mli at openjdk.org> wrote:

>> Hi,
>> Can you help to review the patch?
>> Currently, code in nativeInst_riscv.cpp and macroAssembler_riscv.cpp call each other, which is not right for readability and maintainance.
>> After refactoring, basically only code in nativeInst_riscv.cpp calls code in macroAssembler_riscv.cpp, but not in reverse direction.
>> 
>> Thanks!
>> 
>> * Tests are still running, so far so good.
>
> Hamlin Li has updated the pull request incrementally with one additional commit since the last revision:
> 
>   adjust accessibility

class Assembler : public AbstractAssembler {
public:

  enum {
    instruction_size = 4,

class MacroAssembler: public Assembler {

 public:
  enum {
    instruction_size = 4,


Not sure why you have the same enum defs in both asm and masm?

-------------

PR Comment: https://git.openjdk.org/jdk/pull/19459#issuecomment-2144910630


More information about the hotspot-dev mailing list