RFR: 8332689: RISC-V: Use load instead of trampolines [v7]
Hamlin Li
mli at openjdk.org
Tue Jun 11 20:35:16 UTC 2024
On Fri, 7 Jun 2024 07:14:47 GMT, Fei Yang <fyang at openjdk.org> wrote:
>> src/hotspot/cpu/riscv/macroAssembler_riscv.cpp line 981:
>>
>>> 979: }
>>> 980:
>>> 981: void MacroAssembler::load_link(const address source, Register temp) {
>>
>> maybe modify to `load_jump_link` or `load_link_jump`?
>
> I am considering names like `indirect_jump_link` :-)
I'm not sure, but better have a `jump` in its name, just `load` is misleading.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/19453#discussion_r1635450759
More information about the hotspot-dev
mailing list