RFR: 8327093: Add slice function to BitMap API [v2]

Matias Saavedra Silva matsaave at openjdk.org
Tue Mar 5 18:35:58 UTC 2024


On Tue, 5 Mar 2024 17:05:50 GMT, Ioi Lam <iklam at openjdk.org> wrote:

> But I agree that a `truncate(n)` that means `[n:]` is also non-intuiative.

Looking back at this, I do agree with this and I think it's best for the user to input the entire range. That being said, I think it should be fine to keep `copy_of_range(n)` to signify `[n:]` since it is acting more inline with functions like `slice`.

 Since  `copy_of_range()` is a private function meant to be used within BitMap, I think either `copy_of_range()`, `subset()`, or `slice()` are appropriate names.

-------------

PR Comment: https://git.openjdk.org/jdk/pull/18092#issuecomment-1979402340


More information about the hotspot-dev mailing list