RFR: 8327093: Add slice function to BitMap API [v2]
Ioi Lam
iklam at openjdk.org
Wed Mar 6 03:32:47 UTC 2024
On Wed, 6 Mar 2024 03:15:22 GMT, Ioi Lam <iklam at openjdk.org> wrote:
>> Matias Saavedra Silva has updated the pull request incrementally with one additional commit since the last revision:
>>
>> Axel comments
>
> test/hotspot/gtest/utilities/test_bitMap_truncate.cpp line 83:
>
>> 81: fillBitMap(map, BITMAP_SIZE);
>> 82: testTruncate<ResizableBitMapClass>(0, BITMAP_SIZE, map);
>> 83: }
>
> `testTruncateOneWord()` is pretty easy to understand, but I found it really hard to follow the logic of the other test cases. For example, it took me a while to understand the variable `map` in `testTruncateSame()` is not the same as the `map` in `testTruncate()`.
>
> Could all the tests be rewritten to the same style of `testTruncateOneWord()`, where the entire logic is inside the same function?
Also, I think the contents of this file should be moved inside test_bitMap.cpp, so you don't need to repeat things like TestArenaBitMap.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/18092#discussion_r1513763401
More information about the hotspot-dev
mailing list