RFR: 8312132: Add tracking of multiple address spaces in NMT [v74]
Johan Sjölen
jsjolen at openjdk.org
Mon May 13 11:25:40 UTC 2024
On Fri, 10 May 2024 12:11:56 GMT, Thomas Stuefe <stuefe at openjdk.org> wrote:
>> src/hotspot/share/nmt/vmatree.hpp line 151:
>>
>>> 149:
>>> 150: SummaryDiff release_mapping(position from, position sz) {
>>> 151: Metadata empty;
>>
>> Just a nit, but instead of the Metadata::Metadata() ctor creating an empty object, could we possibly scrap the default ctor and have an explicit static constexpr Metadata empty with invalid stackindex and mtNone as ctor args? I find that nicer to read.
>
> Oh, another thing, maybe rename this to something else. `Metadata` has a clear meaning in hotspot. Maybe something like RegionData?
Hi Thomas, what naming scheme should I use for the empty static RegionData? `EmptyRegionData` or `empty_regiondata`? It can't be `constexpr`, but we can make it `const`.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/18289#discussion_r1598288301
More information about the hotspot-dev
mailing list