RFR: 8332900: RISC-V: refactor nativeInst_riscv.cpp and macroAssembler_riscv.cpp [v2]
Hamlin Li
mli at openjdk.org
Wed May 29 18:29:14 UTC 2024
> Hi,
> Can you help to review the patch?
> Currently, code in nativeInst_riscv.cpp and macroAssembler_riscv.cpp call each other, which is not right for readability and maintainance.
> After refactoring, basically only code in nativeInst_riscv.cpp calls code in macroAssembler_riscv.cpp, but not in reverse direction. The only exception is code related to `membar` where code in macroAssembler_riscv.cpp still calls code nativeInst_riscv.cpp, I'm not sure whether it should be refactored too.
>
> Thanks!
>
> * Tests are still running, so far so good.
Hamlin Li has updated the pull request incrementally with one additional commit since the last revision:
move membar
-------------
Changes:
- all: https://git.openjdk.org/jdk/pull/19459/files
- new: https://git.openjdk.org/jdk/pull/19459/files/f4df2a65..cd408fe0
Webrevs:
- full: https://webrevs.openjdk.org/?repo=jdk&pr=19459&range=01
- incr: https://webrevs.openjdk.org/?repo=jdk&pr=19459&range=00-01
Stats: 80 lines in 4 files changed: 37 ins; 41 del; 2 mod
Patch: https://git.openjdk.org/jdk/pull/19459.diff
Fetch: git fetch https://git.openjdk.org/jdk.git pull/19459/head:pull/19459
PR: https://git.openjdk.org/jdk/pull/19459
More information about the hotspot-dev
mailing list