RFR: 8320318: ObjectMonitor Responsible thread
Axel Boldt-Christmas
aboldtch at openjdk.org
Wed Sep 11 07:18:06 UTC 2024
On Wed, 29 May 2024 12:58:02 GMT, Fredrik Bredberg <fbredberg at openjdk.org> wrote:
> Removed the concept of an ObjectMonitor Responsible thread.
>
> The reason to have an ObjectMonitor Responsible thread was to avoid threads getting stranded due to a hole in the successor protocol. This hole was there because adding the necessary memory barrier was considered too expensive some 20 years ago.
>
> The ObjectMonitor Responsible thread code adds complexity, and doing timed parks just to avoid getting stranded is not the way forward. More info about the problems with the ObjectMonitor responsible thread can be found in [JDK-8320318](https://bugs.openjdk.org/browse/JDK-8320318).
>
> After removing the ObjectMonitor Responsible thread we see increased performance on all supported platforms except Windows. [JDK-8339730](https://bugs.openjdk.org/browse/JDK-8339730) has been created to handle this.
>
> Passes tier1-tier7 on supported platforms.
> x64, AArch64, Riscv64, ppc64le and s390x passes ok on the test/micro/org/openjdk/bench/vm/lang/LockUnlock.java test.
> Arm32 and Zero doesn't need any changes as far as I can tell.
src/hotspot/share/runtime/objectMonitor.cpp line 313:
> 311: // The monitor is private to or already owned by locking_thread which must be suspended.
> 312: // So this code may only contend with deflation.
> 313: assert(locking_thread == Thread::current() || locking_thread->is_obj_deopt_suspend(), "must be");
I feel like the comments and assert now belong in `ObjectMonitor::enter_for_with_contention_mark`.
`enterI_with_contention_mark` should be renamed. This is now a sort of `TryLock_with_contention_mark`.
`add_to_contentions(1);` below could be changed to `contention_mark.extend()`.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/19454#discussion_r1753348561
More information about the hotspot-dev
mailing list