RFR: 8339849: Enumerate opto and C1 stubs, generate enums, names, fields and generator calls [v2]
Andrew Dinn
adinn at openjdk.org
Thu Sep 12 12:40:22 UTC 2024
On Thu, 12 Sep 2024 00:27:42 GMT, Vladimir Kozlov <kvn at openjdk.org> wrote:
>> src/hotspot/share/opto/runtime.cpp line 151:
>>
>>> 149: // defines temporarily rebind the generated names to reference the
>>> 150: // relevant implementations.
>>> 151:
>>
>> I am not 100% happy about using defines to finesse this problem of common C targets.
>>
>> One alternative here is to define methods local to class OptoRuntime which fit the generator naming convention and have them forward the call to the SharedRuntime methods. n.b. I used (local) method forwarding to allow blobs to share common typefunc providers.
>>
>> Another alternative is to declare the C target as a parameter to the opto blob declaration macro. That's more flexible but in almost all cases it repeats information already present and makes understanding and updating the declarations more complex.
>
> This is indeed confusing even with comment.
> I prefer your first suggestion: "define methods local to class OptoRuntime which fit the generator naming convention and have them forward the call to the SharedRuntime methods"
Done.
>> src/hotspot/share/opto/runtime.cpp line 183:
>>
>>> 181: OPTO_STUBS_DO(GEN_OPTO_BLOB, GEN_OPTO_STUB, GEN_OPTO_JVMTI_STUB)
>>> 182:
>>> 183: /*
>>
>> This old code that has been commented out needs to be removed.
>
> Then do it.
Done
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/20936#discussion_r1756771514
PR Review Comment: https://git.openjdk.org/jdk/pull/20936#discussion_r1756774703
More information about the hotspot-dev
mailing list