RFR: 8338995: New Object to ObjectMonitor mapping: PPC64 implementation [v3]

Martin Doerr mdoerr at openjdk.org
Wed Sep 18 10:37:07 UTC 2024


On Tue, 17 Sep 2024 15:42:35 GMT, Richard Reingruber <rrich at openjdk.org> wrote:

>> Martin Doerr has updated the pull request incrementally with two additional commits since the last revision:
>> 
>>  - Remove empty line.
>>  - Improve register usage and readability.
>
> src/hotspot/cpu/ppc/macroAssembler_ppc.cpp line 2825:
> 
>> 2823:       for (int i = 0; i < num_unrolled; i++) {
>> 2824:         ld(tmp3, 0, cache_addr);
>> 2825:         cmpd(CCR0, tmp3, obj);
> 
> Please file a RFE to consistently use either `flag` or `CCR0`.

I'm planning to remove `flag` and use `CCR0` consistently. But I'd like to postpone this and do it after the removal of the old locking modes. (Hoping this will happen soon.)

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/20922#discussion_r1764819653


More information about the hotspot-dev mailing list