RFR: 8322770: Implement C2 VectorizedHashCode on AArch64 [v14]
Andrew Dinn
adinn at openjdk.org
Wed Sep 25 15:26:43 UTC 2024
On Wed, 25 Sep 2024 13:13:13 GMT, Mikhail Ablakatov <duke at openjdk.org> wrote:
>> src/hotspot/cpu/aarch64/aarch64.ad line 16608:
>>
>>> 16606: %}
>>> 16607:
>>> 16608: instruct arrays_hashcode(iRegP_R1 ary, iRegI_R2 cnt, iRegI_R0 result, immI basic_type,
>>
>> I'm not sure why `arrays_hashcode` uses the plural, ditto for the macroassembler method name and stub name/stub generator method name. Other instructions and stubs use the singular e.g. `instruction array_equal_NNN`, `generate_arraycopy_stubs` etc. It would be better to follow that by systematically renaming all occurrences of `arrays_hashcode` to `array_hashcode`.
>
> I believe this is because the Java class that provides the method is called `Java.util.Arrays`. Additionally, `MacroAssembler` [declares](https://github.com/openjdk/jdk/blob/master/src/hotspot/cpu/aarch64/macroAssembler_aarch64.hpp#L1439) `arrays_equals` using the plural form as well.
>
> Systematically changing these names would impact methods which are not directly related to this PR, namely `arrays_equals`, as well as other architectures beside AArch64. I'd suggest to do it in a separate PR in the future (if at all) to keep the focus of this one on `VectorizedHashCode` on AArch64, as indicated by the title.
Ah, yes, that makes sense. Ok, so ignore this.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/18487#discussion_r1775447666
More information about the hotspot-dev
mailing list