RFR: 8353216: Improve VerifyMethodHandles for method handle linkers [v2]
Vladimir Ivanov
vlivanov at openjdk.org
Fri Apr 11 22:48:13 UTC 2025
On Fri, 11 Apr 2025 22:24:27 GMT, Dean Long <dlong at openjdk.org> wrote:
>> Vladimir Ivanov has updated the pull request incrementally with two additional commits since the last revision:
>>
>> - assert_different_registers on x86
>> - jcc->jccb
>
> src/hotspot/cpu/aarch64/methodHandles_aarch64.cpp line 110:
>
>> 108: __ lea(rscratch2, Address(method_holder, InstanceKlass::init_state_offset()));
>> 109: __ ldarb(rscratch2, rscratch2);
>> 110: __ subs(zr, rscratch2, InstanceKlass::fully_initialized);
>
> I think `cmp` might be more readable.
Agree. Changed.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/23950#discussion_r2040381761
More information about the hotspot-dev
mailing list