RFR: 8344232: [PPC64] secondary_super_cache does not scale well: C1 and interpreter [v2]

Richard Reingruber rrich at openjdk.org
Thu Jan 23 13:41:47 UTC 2025


On Wed, 22 Jan 2025 22:00:21 GMT, Martin Doerr <mdoerr at openjdk.org> wrote:

>> This is extremely hard to see.
>> L2154 with the "blr" in `check_klass_subtype_slow_path_linear` looks redundant to me. It should be removed if you agree.
>> The comment here should be adapted then too.
>> Also the comment at macroAssembler_ppc.cpp:2258 needs to be adapted because fallthrough from `check_klass_subtype_slow_path` does not mean "not successful". `L_failure` could be renamed to `L_fast_path_failure`
>
> I think `L_failure` is correct. And it's used the same way on all platforms.

Ah, I see. I missed that `L_failure` is passed by reference
https://github.com/openjdk/jdk/blob/c00557f8f53ff729c8a1857a4ffcc585d3f8c6c4/src/hotspot/cpu/ppc/macroAssembler_ppc.cpp#L2159-L2168
Therefore it's never null and `L_failure` is reached if, and only if the result of the type check is negative.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/22881#discussion_r1926994939


More information about the hotspot-dev mailing list