RFR: 8351949: RISC-V: Cleanup and enable store-load peephole for membars [v3]

Robbin Ehn rehn at openjdk.org
Mon Mar 17 12:35:43 UTC 2025


On Mon, 17 Mar 2025 11:07:30 GMT, Fei Yang <fyang at openjdk.org> wrote:

>> Robbin Ehn has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains six additional commits since the last revision:
>> 
>>  - Merge branch 'master' into tso-merge
>>  - Review comments
>>  - Fixed ws
>>  - Revert NC
>>  - Fixed comment
>>  - UseNewCode
>
> src/hotspot/cpu/riscv/riscv.ad line 7967:
> 
>> 7965:   size(0);
>> 7966: 
>> 7967:   format %{ "no_membar_rvtso elided/tso (empty encoding)" %}
> 
> Here: s/no_membar_rvtso/unnecessary_membar_rvtso/

Fixed

> src/hotspot/cpu/riscv/riscv.ad line 8007:
> 
>> 8005: // RVWMO
>> 8006: 
>> 8007: instruct membar_rvwmo_aqcuire() %{
> 
> Maybe it's better to put `_rvwmo` as a suffix? Like `membar_aqcuire_rvwmo`. Similar for other match rules like `membar_rvwmo_release`, `membar_rvwmo_storestore`, `membar_rvwmo_lock` and `membar_rvwmo_volatile`.

Fixed

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/24035#discussion_r1998631693
PR Review Comment: https://git.openjdk.org/jdk/pull/24035#discussion_r1998631992


More information about the hotspot-dev mailing list