RFR: 8352159: RISC-V: add more zfa support [v4]

Hamlin Li mli at openjdk.org
Wed Mar 19 09:30:08 UTC 2025


On Wed, 19 Mar 2025 07:41:02 GMT, Fei Yang <fyang at openjdk.org> wrote:

>> Hamlin Li has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains six commits:
>> 
>>  - merge master
>>  - fix fli_h
>>  - fix rFlagsReg
>>  - refactor min/max
>>  - min/max
>>  - initial commit
>
> src/hotspot/cpu/riscv/assembler_riscv.hpp line 446:
> 
>> 444:       case 0x7c00 : return 29;
>> 445:       // case 0x7c00 : return 30; // redundant with 29
>> 446:       case 0x7e00 : return 31;
> 
> This switch-case seems nontrivial (Same for for all S & D variants). One possible enhancement to speed up might be putting the values in a table and doing a binary search.

In this case, I think the compiler (gcc or clang) will be able to automatically generate a binary research rather than a linear search, so we don't have to write the code manually. And keep the code as it is is more readable.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/24081#discussion_r2002867954


More information about the hotspot-dev mailing list