RFR: 8356390: Rename ResolvedIndyEntry::set_flags to set_has_appendix [v4]

David Holmes dholmes at openjdk.org
Mon May 12 02:19:00 UTC 2025


On Fri, 9 May 2025 12:37:34 GMT, Johan Sjölen <jsjolen at openjdk.org> wrote:

>> The `set_flags` function really only sets whether it has an appendix or not, and there's a separate `set_resolution_failed` method just below that also alters the flag. Just rename this to `set_has_appendix`
>
> Johan Sjölen has updated the pull request incrementally with one additional commit since the last revision:
> 
>   I should really stop pushing w/o first building

Looks good. Thanks

src/hotspot/share/oops/resolvedIndyEntry.hpp line 73:

> 71:   enum {
> 72:     resolution_failed_shift    = 0,
> 73:     has_appendix_shift        = 1,

Suggestion:

    resolution_failed_shift = 0,
    has_appendix_shift      = 1,

-------------

Marked as reviewed by dholmes (Reviewer).

PR Review: https://git.openjdk.org/jdk/pull/25092#pullrequestreview-2831641647
PR Review Comment: https://git.openjdk.org/jdk/pull/25092#discussion_r2083716164


More information about the hotspot-dev mailing list