<div dir="ltr">Hi,<div><br></div><div>several functions in the os:: name scope are deliberately named like the official counterparts they replace:<br></div><div><br></div><div>os::malloc, os::free, os::strdup, os::realloc, os::recv, os::send, os::connect, os::signal...</div><div><br></div><div>There may be more. Some of them argument-match their counterparts (e.g. os::free), while others don't.</div><div><br></div><div>Since the os:: variants can be called inside the os:: namespace with omitting the leading os::, name confusions are possible. "free(p)" means something different in global scope or inside an os:: function.</div><div><br></div><div>This can lead to problems that are difficult to find, e.g., mismatched (os::)malloc->(os::)free with the potential to corrupt the C-heap:</div><div><br></div><div><a href="https://bugs.openjdk.org/browse/JDK-8289477">https://bugs.openjdk.org/browse/JDK-8289477</a></div><div><br></div><div>And I remember having similar problems in the past. They don't happen often, but if they do, they take some investigation time since they are rarely obvious.</div><div><br></div><div>I discussed the above problem with the muslc devs <a href="https://www.openwall.com/lists/musl/2022/06/29/3" rel="noreferrer" target="_blank">https://www.openwall.com/lists/musl/2022/06/29/3</a>, and their position is understandable that we should not use names of standard functions.</div><div><br></div><div>So I wonder if we should do that. Rename os::<function> to something like os::<prefix><function>. And what the prefix or suffix would be.</div><div><br></div><div>Thanks, Thomas</div><div><br></div></div>