Request for review (vs) - 6843292

John Coomes John.Coomes at sun.com
Thu Jul 30 17:06:56 UTC 2009


Jon Masamitsu (Jon.Masamitsu at Sun.COM) wrote:
> 
> 6843292: "Expect to be beyond new region unless impacting another 
> region" assertion too strong"
> 
> Relax the assertion for the case where the new region extends into the 
> guard page.
> 
> http://cr.openjdk.java.net/~jmasa/6843292

Looks fine.  You could change this:

 259     HeapWord* new_end_for_commit = new_end_aligned;
 260 
 261     debug_only(bool guarded = false;)
 262     if (new_end_for_commit > _guard_region.start()) {
 263       new_end_for_commit = _guard_region.start();
 264       debug_only(guarded = true;)
 265     }

to this:

    DEBUG_ONLY(const bool guarded = new_end_aligned > _guard_region.start());
    HeapWord* new_end_for_commit = MIN2(new_end_aligned, _guard_region.start());

which is easier to read (IMHO, of course).

-John




More information about the hotspot-gc-dev mailing list