RFR (S): 7095194: G1: HeapRegion::GrainBytes, GrainWords, and CardsPerRegion should be size_t

John Coomes John.Coomes at oracle.com
Tue Sep 27 00:06:42 UTC 2011

John Cuthbertson (john.cuthbertson at oracle.com) wrote:
> Hi Everyone,
> Can I have a couple of volunteers review these changes? The webrev can 
> be found at: http://cr.openjdk.java.net/~johnc/7095194/webrev.0/
> Background: As part of the review comments for 7092245, someone 
> suggested that a better solution might be to declare 
> HeapRegion::GrainBytes as a size_t. I went with the original and smaller 
> fix to make it easier to back port the fix into hs22. These changes 
> address that review comment - namely declare GrainBytes (and by 
> extension GrainWords and CardsPerRegion) as a size_t.

Looks good to me.  And thank you for getting rid of the cast noise.


More information about the hotspot-gc-dev mailing list