RFR (S): 7112912:Message "Error occurred during initialization of VM" on boxes with lots of RAM
Thomas Schatzl
thomas.schatzl at oracle.com
Mon Mar 25 17:28:25 UTC 2013
Hi Jon,
On Fri, 2013-03-22 at 14:24 -0700, Jon Masamitsu wrote:
> Thomas,
>
> Thanks for the extra effort. A comment not about correctness
> but more for readability.
>
> > + if (is_allocatable(upper_limit)) {
> > + *limit = upper_limit;
> > + } else if (upper_limit < min_allocation_size) {
> > + *limit = upper_limit;
> > + } else if (!is_allocatable(min_allocation_size)) {
> > + // we found that not even min_allocation_size is allocatable. Return it
> > + // anyway. There is no point to search for a better value any more.
> > + *limit = min_allocation_size;
>
> In the first "else if" if you changed it to (upper_limit <=
> min_allocation_size)
> can you eliminate the second "else if" like this
>
> + if (is_allocatable(upper_limit)) {
> + *limit = upper_limit;
> + } else if (upper_limit <= min_allocation_size) {
> + *limit = upper_limit;
>
> And it might read more easily as
>
> + if (is_allocatable(upper_limit) ||
> +upper_limit <= min_allocation_size) {
> + *limit = upper_limit;
a new webrev with your suggested change is available at
http://cr.openjdk.java.net/~tschatzl/7112912/webrev.2/
Again, the change passed jprt.
Hth,
Thomas
More information about the hotspot-gc-dev
mailing list