RFR (M): 7163191 G1: introduce a "heap spanning table" abstraction
Thomas Schatzl
thomas.schatzl at oracle.com
Wed Sep 25 09:02:53 UTC 2013
Hi,
On Tue, 2013-09-24 at 11:45 +0200, Bengt Rutisson wrote:
> Hi Thomas,
>
> Sorry for taking so long to get back to you about this.
>
> Looks good.
>
> Thanks for adding the test! One minor nit about the test:
>
> Lately there has been some unit tests added that use a wrapper function
> like test_g1biasedarray() that you introduce. These tests, for example
> TestReservedSpace_test(), use a forward declaration in jni.cpp rather
> than including the hpp file and they also use a naming convention that
> kind of mimics a static method on the class to be tested. This is pretty
> new, so I don't know if this is the accepted way to do it, but unless
> you have strong feelings I suggest following that same pattern.
Fixed. See http://cr.openjdk.java.net/~tschatzl/7163191/webrev.2/
Thanks,
Thomas
More information about the hotspot-gc-dev
mailing list