Request for review: 8016302: Change type of the number of GC workers to unsigned int (2)

Stefan Karlsson stefan.karlsson at oracle.com
Fri Apr 4 08:10:58 UTC 2014


I see that this change was pushed although I opposed the usage of 
UINT32_FORMAT, both online and offline:
http://hg.openjdk.java.net/jdk9/hs-gc/hotspot/rev/7901f4c9c3cc

I've sent out this review request to get rid of the incorrect usages of 
UINT32_FORMAT and INT32_FORMAT from the GC code:
http://mail.openjdk.java.net/pipermail/hotspot-gc-dev/2014-April/009809.html

StefanK

On 2014-04-02 18:17, Vladimir Kempik wrote:
> Hi all,
>
> Could I have a couple of reviews for this change?
>
> http://cr.openjdk.java.net/~vkempik/8016302/webrev.04/
>
> In 7121618 variables representing GC workers (worker id, worker id 
> offset) have been changed from int to unsigned int.
>
> Since then, code reintroduced the use of int's for this type of 
> variable; fixing this by aligning the code to use uints for ints.
>
> Since last september the fix was updated for jdk9 and size_t was 
> replaced with uint in
> dirtyCardQueue.hpp,
>
>   54 bool apply_closure(CardTableEntryClosure* cl,
>   55                      bool consume = true,
>   56                      size_t worker_i = 0);
>
>   99   // The number of parallel ids that can be claimed to allow
> collector or
>  100   // mutator threads to do card-processing work.
>  101   static size_t num_par_ids();
>
> Thanks,
> Vladimir
>




More information about the hotspot-gc-dev mailing list