RFR: 8047821: G1 Does not use the save_marks functionality as intended

Mikael Gerdin mikael.gerdin at oracle.com
Tue Jun 24 12:10:47 UTC 2014


Hi!

On Monday 23 June 2014 16.26.00 Mikael Gerdin wrote:
> Hi!
> 
> As part of a larger effort to detach G1's HeapRegion from ContiguousSpace[1]
> and as a general cleanup we should rename the save_marks and
> set_saved_marks methods on HeapRegion. They are not used with
> oops_since_saved_marks_iterate and cause more confusion than anything.
> 
> This change is part of a set of 4 changes: 8047818, 8047819, 8047820,
> 8047821 which are needed to refactor the HeapRegion class and its
> superclasses in order to simplify the G1 class unloading change which is
> coming.
> 
> Bug:
> https://bugs.openjdk.java.net/browse/JDK-8047821
> Webrev:
> http://cr.openjdk.java.net/~mgerdin/8047821/webrev/

Stefan discovered some more dead code in HeapRegion, here are a new set of 
webrevs:

http://cr.openjdk.java.net/~mgerdin/8047821/webrev.0_to_1/
http://cr.openjdk.java.net/~mgerdin/8047821/webrev.1/

/Mikael

> 
> [1] https://bugs.openjdk.java.net/browse/JDK-8047818
> 
> Thanks
> /Mikael




More information about the hotspot-gc-dev mailing list