RFR: 8036696: Add metaspace gc threshold to metaspace summary trace event

Erik Helin erik.helin at oracle.com
Mon Mar 10 09:22:18 UTC 2014


Hi Jon,

thanks for having a look at the patch!

On 2014-03-06 23:30, Jon Masamitsu wrote:
> Erik,
>
> Why the choice of the variable name _gc_threshold instead of the
> variable name _capacity_until_gc (the same variable name as
> in Metaspace)?  Using the label "GC Threshold" seems ok.  I
> can understand not making that title too geeky.

Since the the meaning of the word "capacity" has caused me (us?) some 
problems in the metaspace code (is it words/bytes? is it committed/used 
or something else?), I believe it is better to use that does not imply 
to "what" the high-water mark is compared. The name _capacity_until_gc 
implies that we compare the value to some kind of capacity, whereas the 
name gc_threshold just states that this is a some kind of limit.

Ideally, I would like to see us rename MetaspaceGC::_capacity_until_gc 
to MetaspaceGC::_gc_threshold, but that is another patch.

What do you think?

Thanks,
Erik

> Otherwise, looks good.
>
> Jon
>
> On 3/6/2014 12:07 AM, Erik Helin wrote:
>> Hi all,
>>
>> this change add the metaspace GC threshold
>> (Metaspace::_capacity_until_gc) to the trace event
>> vm/gc/heap/metaspace_summary.
>>
>> Enhancement:
>> https://bugs.openjdk.java.net/browse/JDK-8036696
>>
>> Webrev:
>> http://cr.openjdk.java.net/~ehelin/8036696/webrev.00/
>>
>> Testing:
>> - JFR JTREG tests
>> - JPRT
>>
>> Thanks,
>> Erik
>



More information about the hotspot-gc-dev mailing list