RFR: 8042298 - Remove the names gen0 and gen1 from the GC code
Stefan Johansson
stefan.johansson at oracle.com
Wed May 14 13:11:19 UTC 2014
Hi Jesper,
Thanks for doing this work. Here are some comments:
src/share/vm/gc_implementation/g1/g1CollectorPolicy.cpp:
* TraceGen0Time and TraceGen1Time should be changed to TraceYoungTime
and TraceOldTime for consistency, and I guess that will need a CCC request.
src/share/vm/gc_implementation/concurrentMarkSweep/concurrentMarkSweepGeneration.hpp
* CollectGen0First -> CollectYoungFirst, same as above. Also used in
tenuredGeneration.hpp.
src/share/vm/gc_implementation/g1/g1CollectorPolicy.hpp
* Comment starting on line 41 mentions TraceGen0Time and gen1.
As an additional comment, I think that GenCollectedHeap::get_gen(int)
should be broken up into two functions get_young() and get_old(). I get
that this was left to a later patch to avoid having code/logic changes
in this patch but I think the change is so little that it makes sense to
do it in this patch. I would like to avoid having code like, even if it
is for a brief period of time:
Generation* young = gch->get_gen(0);
Thanks,
Stefan
On 2014-05-02 03:39, Jesper Wilhelmsson wrote:
> Hi,
>
> This is a step towards removing the _generations array. The names gen0
> and gen1 are replaced with young and old to use a more standardized
> vocabulary.
>
> Webrev: http://cr.openjdk.java.net/~jwilhelm/8042298/webrev/
>
> Bug: https://bugs.openjdk.java.net/browse/JDK-8042298
>
> Thanks,
> /Jesper
More information about the hotspot-gc-dev
mailing list