RFR (3*XS): Backports to 8u40 of 8054819, 8055919, 8056043
Jon Masamitsu
jon.masamitsu at oracle.com
Tue Sep 2 20:33:24 UTC 2014
Thomas,
No correctness issues so looks good.
A few minor things. Ignore them if they would make future backports
less automatic.
Could you fix the indentation (line-up the variables) here?
http://cr.openjdk.java.net/~tschatzl/8054819/webrev.8u40/src/share/vm/gc_implementation/g1/g1CollectedHeap.cpp.udiff.html
class RebuildRegionSetsClosure : public HeapRegionClosure {
private:
bool _free_list_only;
HeapRegionSet* _old_set;
- HeapRegionSeq* _hrs;
+ HeapRegionManager* _hrm;
size_t _total_used;
also
class VerifyRegionListsClosure : public HeapRegionClosure {
private:
HeapRegionSet* _old_set;
HeapRegionSet* _humongous_set;
- HeapRegionSeq* _hrs;
+ HeapRegionManager* _hrm;
http://cr.openjdk.java.net/~tschatzl/8054819/webrev.8u40/src/share/vm/gc_implementation/g1/heapRegionRemSet.cpp.udiff.html
- RegionIdx_t from_hrs_ind = (RegionIdx_t) from_hr->hrs_index();
+ RegionIdx_t from_hrs_ind = (RegionIdx_t) from_hr->hrm_index();
Variable name to from_hrm_ind ?
which would flow into this change
- "overflow(f: %d, t: %d)",
- tid, from_hrs_ind, cur_hrs_ind);
+ "overflow(f: %d, t: %u)",
+ tid, from_hrs_ind, cur_hrm_ind);
from_hrs_ind ?
Reviewed.
Jon
On 8/28/2014 2:45 AM, Thomas Schatzl wrote:
> Hi all,
>
> can I have a few reviews for these backports that have a few minor
> merge errors?
>
> 8054819: Rename HeapRegionSeq to HeapRegionManager:
>
> There were some merge failures due to whitespace differences:
>
> - at HeapRegionManager::HeapRegionManager()
> - in heapRegionRemSet.cpp line 497:
>
> if (G1TraceHeapRegionRememberedSet) {
> gclog_or_tty->print_cr(" [tid %d] sparse table entry "
> "overflow(f: %d, t: %d)", (*)
> tid, from_hrs_ind, cur_hrs_ind);
> }
>
> (*) the second %d has already been fixed in 9 but not in 8u
>
> Original webrev:
> http://cr.openjdk.java.net/~tschatzl/8054819/webrev/
> New webrev:
> http://cr.openjdk.java.net/~tschatzl/8054819/webrev.8u40/
>
> 8055919: Remove dead code in G1 concurrent marking code
>
> Merge failures due to typos not fixed in 8uX:
>
> concurrentMark.hpp:
>
> line 946: 8u has "reponsibility", 9 has "responsibility"
> line 950: 8u has "unconditinally", 9 has "unconditionally"
>
> concurrentMark.inline.hpp
>
> line 108: 8u has "incremement", 9 has "increment"
> line 225: 8u has "unconditinally", 9 has "unconditionally"
>
> Original webrev:
> http://cr.openjdk.java.net/~tschatzl/8055919/webrev.1/
> New webrev:
> http://cr.openjdk.java.net/~tschatzl/8055919/webrev.8u40
>
> 8037925: CMM Testing: an allocated humongous object at the end of the
> heap should not prevents shrinking the heap
>
> had to backport this one too, no failures though.
>
> 8056043: G1 does not uncommit within the heap after JDK-8038423
>
> There are merge errors in the test case
> test/gc/g1/TestHumongousShrinkHeap.java that has been re-enabled in this
> CR. The 8u test case does not have the @ignore line.
> This has been added in another CR (8044132: Quarantine unstable/broken
> GC tests), but that one has dependencies on many other unrelated CRs, so
> I did not try to backport it.
>
> Original webrev:
> http://cr.openjdk.java.net/~tschatzl/8056043/webrev/
> New webrev:
> http://cr.openjdk.java.net/~tschatzl/8056043/webrev.8u40/
>
> Please review these differences.
>
> Thanks,
> Thomas
>
>
More information about the hotspot-gc-dev
mailing list