RFR (S): 8073052: Rename and clean up the allocation manager hierarchy in g1Allocator.?pp

Jon Masamitsu jon.masamitsu at oracle.com
Wed Apr 1 17:23:43 UTC 2015



On 3/31/2015 3:28 AM, Thomas Schatzl wrote:
> Hi again,
>
> On Tue, 2015-03-31 at 09:32 +0200, Thomas Schatzl wrote:
>> Hi Jon,
>>
>> On Sun, 2015-03-29 at 12:35 -0700, Jon Masamitsu wrote:
>>> Thomas,
>>>
>>> It's not clear to me that the name change
>>> G1ParGCAllocBuffer to G1PLAB is a change for the better.
>>>   From the base class name  ParGCAllocBuffer, I could guess
>>> the G1 version is G1ParGCAllocBuffer but I would not guess
>>> G1PLAB.  Can you motivate that name (G1PLAB) for me?
>> "PLAB" is a commonly used and more concise abbreviation for this kind of
>> data structure. We ourselves use "Promotion Local Allocation
>> Buffer" (sometimes also "Parallel Local...") e.g. in the description of
>> the *PLAB* switches. Also in literature (see some GC papers) that name
>> is used for this kind of data structure (note that they apparently use
>> our naming).
>>
>> ParGCAllocBuffer misses the information about it being about
>> "promotion"/"parallel" and "local" too, and is longer to type.
>>
>> I think it is prudent to follow existing naming for stuff like that
>> instead of re-inventing it within the same code.
>    talked to StefanK a bit about this, and we think that it would be good
> to do this renaming in JDK-8074546 before this change goes in.
>
> This would avoid having the subclass renamed temporarily, but not the
> parent.

Excellent.  Thanks.

Jon

>
> I will provide a new webrev then.
>
> Thanks for looking at this.
>
> Thanks,
>    Thomas
>
>




More information about the hotspot-gc-dev mailing list