RFR(s): 8077417: Cleanup of Universe::initialize_heap()
Per Liden
per.liden at oracle.com
Fri Apr 10 14:57:57 UTC 2015
Hi,
Universe::initialize_heap() is kind of messy as it contains lots of #if
INCLUDE_ALL_GCS, this patch tries to make that code a bit more readable.
Also, all collectors except ParallelScavenge take their CollectorPolicy
as an argument to the constructor. This patch aligns ParallelScavenge to
this pattern to further make the code in initialize_heap() more readable.
Bug: https://bugs.openjdk.java.net/browse/JDK-8077417
Webrev: http://cr.openjdk.java.net/~pliden/8077417/webrev.0/
This patch build on top of two other patches currently out for review,
these are:
http://cr.openjdk.java.net/~pliden/8077413/webrev.0/
http://cr.openjdk.java.net/~pliden/8077415/webrev.0/
cheers,
/Per
More information about the hotspot-gc-dev
mailing list