RFR (M): 8027962: Per-phase timing measurements for strong roots processing

Thomas Schatzl thomas.schatzl at oracle.com
Wed Feb 18 14:36:14 UTC 2015


Hi Bengt,

  thanks for the review.

On Tue, 2015-02-17 at 16:03 +0100, Bengt Rutisson wrote:
> > JIRA:
> > https://bugs.openjdk.java.net/browse/JDK-8027962
> > Webrev:
> > http://cr.openjdk.java.net/~tschatzl/8027962/webrev/
> 
> I think it would be good if we can make sure that the GC code does not 
> leak in to runtime/timer. Not sure exactly how, but it would be good to 
> try some change out to avoid this dependency.

Actually there is a really simple way of doing that by declaring an
interface with the required methods and use that.

> TestGCLogMessages.java
> 
> I find it a little confusing that the instance variable messages has the 
> same name as the parameter to the method checkMessagesAtLevel(). Could 
> you change the name of one of them?
> 
>    47     LogMessageWithLevel messages[] = new LogMessageWithLevel[] {
> 
>    79     void checkMessagesAtLevel(OutputAnalyzer output, 
> LogMessageWithLevel messages[], int level) throws Exception {
> 
> Also, what do you think about using an enum instead of using the integer 
> values 2, 3 etc for levels?

All fixed.

New webrevs at:
http://cr.openjdk.java.net/~tschatzl/8027962/webrev.1/ (full)
http://cr.openjdk.java.net/~tschatzl/8027962/webrev.0_to_1/
(incremental)

Testing: jprt

Thanks,
  Thomas




More information about the hotspot-gc-dev mailing list