Request for Review (s) - 7012980: PSOldGen is increased if there is no space in Metaspace

Jon Masamitsu jon.masamitsu at oracle.com
Wed Jul 8 15:50:23 UTC 2015


Thomas,

Thanks for the review.

On 07/08/2015 03:59 AM, Thomas Schatzl wrote:
> Hi Jon,
>
> On Thu, 2015-06-18 at 09:02 -0700, Jon Masamitsu wrote:
>> A recent integration collided with my patch so I had to merge
>> and redo the webrev.  Previously in addition to the fix there was
>> a clean up that introduce a method is_system_gc().  The need
>> for is_system_gc() was overridden by the already added
>> is_user_requested_gc().
>>
>> New webrev
>>
>> http://cr.openjdk.java.net/~jmasa/7012980/webrev.02/
>>
>> Thanks.
>    looks good.
>
> One minor nit I can see is the naming of "should_update_promo_stats" - I
> am not sure why it is has "promo" in the name.
>
> The other, with the "eden" in the name can be immediately associated
> with young gen, the other not so much imo.
>
> Maybe there is a better name of it, but maybe it fits because other
> variables related to allocation in the old/tenured gen also have "promo"
> in their name. So it is probably best to keep it for uniformity.

Yes, the "promo" name is historic.   The
ParallelGC ergonomics tries to manage the amount of space in
the old gen available for promotions (i.e., the free space in the
old gen).  With eden always being empty at the end of a young
GC, the size of eden relates to how much time until the next
young GC.  Similarly "promo" relates to how long until the
next full GC.

Jon
>
> Thanks,
>    Thomas
>
>




More information about the hotspot-gc-dev mailing list