RFR (s): 8143252: Clean up G1CollectedHeap interface

Thomas Schatzl thomas.schatzl at oracle.com
Thu Nov 19 09:05:13 UTC 2015


Hi Derek,

On Thu, 2015-11-19 at 00:01 -0500, Derek White wrote:
> This is a small cleanup that:
>       * Deletes an undefined method declaration
>         G1CollectedHeap::collected_locked()
>       * Renames method to be more descriptive:
>         G1CollectedHeap::do_collection() ---> do_full_collection()
>       * Removes unused parameter "word_size" from (newly renamed)
>         do_full_collection() and
>         resize_if_necessary_after_full_collection() 
> CR: https://bugs.openjdk.java.net/browse/JDK-8143252
> Webrev: http://cr.openjdk.java.net/~drwhite/8143252/webrev.01/
> 
> Ran jprt.
> 
Please fix this random use of newlines:

1479 void
1480 G1CollectedHeap::
1481 resize_if_necessary_after_full_collection() {

Also, I think the "1478 // This code is mostly copied from
CardGeneration::compute_new_size." is just confusing. There does not
seem to be a too big relation to the two methods any more.

I would like to have it removed. It is just confusing to me.

Thanks,
  Thomas





More information about the hotspot-gc-dev mailing list