Request for Review (s) - 8157240: GC task trace logging is incomprehensible

Thomas Schatzl thomas.schatzl at oracle.com
Thu Jun 30 08:40:05 UTC 2016


Hi Jon,

On Fri, 2016-06-24 at 19:33 -0700, Jon Masamitsu wrote:
> https://bugs.openjdk.java.net/browse/JDK-8157240
> 
> Fix the logging for GC worker creation so that it is consistent and
> adds the GC worker name to the logging.
> 
> http://cr.openjdk.java.net/~jmasa/8157240/webrev.00/index.html
> 
> Tested by hand to verify output and with
> TestDynamicNumberOfGCThreads.java.

 - How is it possible that the worker_name() methods return NULL? Is
this supposed to help for threads not created yet?

If that were the case, the logging code would crash too.

Wouldn't that be an error in any case, and as such, I would prefer some
assert in the worker_name() methods for invalid index (or something
like this).

- The indentation of the parameters for

+  static void log_worker_creation(WorkerType* holder,
+                           uint previous_created_workers,
+                           uint active_workers,
+                           uint created_workers,
+                           bool initializing) {

in workerManager.hpp is wrong

- the output seems to really be some kind of developer oriented debug
output, mentioning method names and variable names. Maybe something
more readable would be nice, but then again it is some trace level
message.

No particular opinion here, but maybe somebody else has a similar
opinion.

- would it be possible to write a short regression test checking the
output?

Thanks,
  Thomas



More information about the hotspot-gc-dev mailing list