Request for review JDK-8151045,,Remove code duplication in PLABStats/G1EvacStats::adjust_desired_plab_sz
Alexander Harlap
alexander.harlap at oracle.com
Thu Feb 23 18:03:32 UTC 2017
Hi Thomas,
Thank you very much for the review
On 2/23/2017 4:32 AM, Thomas Schatzl wrote:
> Hi,
>
> On Wed, 2017-02-22 at 15:41 -0500, Alexander Harlap wrote:
>> Next version:
>>
>> http://cr.openjdk.java.net/~aharlap/8151045/webrev.02/
>>
>> Alex
>>
> Before pushing, please fix plab.cpp line 177: please remove the extra
> spaces after "wasted_frac", or align the "=" above.
I aligned '=' symbol:
176 size_t allocated = MAX2(_allocated, size_t(1));
177 double wasted_frac = (double)_unused / (double)allocated;
178 size_t target_refills = (size_t)((wasted_frac *
TargetSurvivorRatio) / TargetPLABWastePct);
> Looks good otherwise (and I do not need to re-review this whitespace
> change).
>
> Thomas
>
Alex
More information about the hotspot-gc-dev
mailing list