February 2018 Archives by author
Starting: Thu Feb 1 07:15:02 UTC 2018
Ending: Wed Feb 28 07:26:00 UTC 2018
Messages: 181
- RFR(M): 8195103: Refactor ReduceInitialCardMarks to not assume all GCs use card marks
Kim Barrett
- RFR: 8187577: JVM crash during gc doing concurrent marking
Kim Barrett
- RFR (XS): 8196883: G1RemSet::refine_card_concurrently doesn't need to check for cards in collection set
Kim Barrett
- RFR (S): 8196602: Change HeapRegionClosure to comply to naming conventions
Kim Barrett
- RFR (S): 7127700: G1: Replace G1PLAB with PLAB
Kim Barrett
- RFR (S): 7127700: G1: Replace G1PLAB with PLAB
Kim Barrett
- [10] RFR: 8197968: [Backout] JDK-8196883 G1RemSet::refine_card_concurrently doesn't need to check for cards in collection set
Kim Barrett
- RFR(s): 8197992: Move the OopStorage::ParState type out of inline.hpp
Kim Barrett
- RFR(xs): 8198271: Make CollectedHeap::create_heap_space_summary() virtual
Kim Barrett
- RFR(s): 8198268: Add time argument to ConcurrentGCTimer::register_gc_pause_start/_end
Kim Barrett
- RFR(s): 8198267: Allow GCId::current_raw() calls from non-NamedThreads
Kim Barrett
- RFR(s): 8198267: Allow GCId::current_raw() calls from non-NamedThreads
Kim Barrett
- RFR(s): 8198267: Allow GCId::current_raw() calls from non-NamedThreads
Kim Barrett
- RFR: 8198530: Move _gc_policy_counters from GenCollectorPolicy to GenCollectedHeap
Kim Barrett
- RFR: 8198530: Move _gc_policy_counters from GenCollectorPolicy to GenCollectedHeap
Kim Barrett
- RFR: 8198528: Move GenerationSpecs from GenCollectorPolicy to GenCollectedHeap
Kim Barrett
- G1's parallel full GC significantly increases wasted space in Old regions
Man Cao
- G1's parallel full GC significantly increases wasted space in Old regions
Man Cao
- [8u] RFR for backport of JDK-8148175: C1: G1 barriers don't preserve FP registers to jdk8u-dev
Muthusamy Chinnathambi
- [8u] RFR for backport of JDK-8148175: C1: G1 barriers don't preserve FP registers to jdk8u-dev
Muthusamy Chinnathambi
- RFR(XS): 8198510: Limit GC threads for small Java heap
Doerr, Martin
- RFR(XS): 8198510: Limit GC threads for small Java heap
Doerr, Martin
- RFR(XS): 8198510: Limit GC threads for small Java heap
Doerr, Martin
- RFR(XS): 8198510: Limit GC threads for small Java heap
Doerr, Martin
- RFR: JDK-8175312: SA: clhsdb: Provide an improved heap summary for 'universe' for G1GC
Jini George
- RFR: JDK-8175312: SA: clhsdb: Provide an improved heap summary for 'universe' for G1GC
Jini George
- RFR: JDK-8175312: SA: clhsdb: Provide an improved heap summary for 'universe' for G1GC
Jini George
- RFR [Urgent] [Backout] JDK-8196602 Change HeapRegionClosure to comply to naming conventions
Tobias Hartmann
- RFR (XS): 8196883: G1RemSet::refine_card_concurrently doesn't need to check for cards in collection set
Erik Helin
- RFR (S): 8195115: G1 Old Gen MemoryPool CollectionUsage.used values don't reflect mixed GC results
Erik Helin
- RFR: 8198420: Remove unused extension point AllocationContextStats
Erik Helin
- RFR: 8198430 : Remove G1Allocator extension point
Erik Helin
- RFR: 8198431: Remove G1FullCollector extension point
Erik Helin
- RFR: 8198424: Remove G1AllocationContext
Erik Helin
- RFR (S): 8195115: G1 Old Gen MemoryPool CollectionUsage.used values don't reflect mixed GC results
Erik Helin
- RFR (S): 8195115: G1 Old Gen MemoryPool CollectionUsage.used values don't reflect mixed GC results
Hohensee, Paul
- RFR (S): 8195115: G1 Old Gen MemoryPool CollectionUsage.used values don't reflect mixed GC results
Hohensee, Paul
- RFR (S): 8195115: G1 Old Gen MemoryPool CollectionUsage.used values don't reflect mixed GC results
Hohensee, Paul
- RFR (S): 8195115: G1 Old Gen MemoryPool CollectionUsage.used values don't reflect mixed GC results
Hohensee, Paul
- RFR (S): 8195115: G1 Old Gen MemoryPool CollectionUsage.used values don't reflect mixed GC results
Hohensee, Paul
- RFR (S): 8195115: G1 Old Gen MemoryPool CollectionUsage.used values don't reflect mixed GC results
Hohensee, Paul
- RFR(XS) : 8197113 : combine multiple @key tags in jtreg tests
Igor Ignatyev
- PING: RFR: JDK-8153333: [REDO] STW phases at Concurrent GC should count in PerfCounter
Stefan Johansson
- PING: RFR: JDK-8153333: [REDO] STW phases at Concurrent GC should count in PerfCounter
Stefan Johansson
- PING: RFR: JDK-8153333: [REDO] STW phases at Concurrent GC should count in PerfCounter
Stefan Johansson
- PING: RFR: JDK-8153333: [REDO] STW phases at Concurrent GC should count in PerfCounter
Stefan Johansson
- RFR (S): 8196602: Change HeapRegionClosure to comply to naming conventions
Stefan Johansson
- RFR (S): 7127700: G1: Replace G1PLAB with PLAB
Stefan Johansson
- RFR (S): 7127700: G1: Replace G1PLAB with PLAB
Stefan Johansson
- RFR(xs): 8198269: Allow GCCauseSetter to be used outside of safepoints
Stefan Johansson
- G1's parallel full GC significantly increases wasted space in Old regions
Stefan Johansson
- RFR: 8198420: Remove unused extension point AllocationContextStats
Stefan Johansson
- RFR: 8198373: Remove CollectorPolicy::is/as functions
Stefan Johansson
- RFR: 8198511: Move allocation functions from GenCollectorPolicy to GenCollectedHeap
Stefan Johansson
- RFR(XS): 8198510: Limit GC threads for small Java heap
Stefan Johansson
- RFR: 8198525: Move _size_policy out of GenCollectorPolicy into GenCollectedHeap
Stefan Johansson
- RFR: 8198509: Move satisfy_failed_metadata_allocation out from CollectorPolicy
Stefan Johansson
- RFR: 8198528: Move GenerationSpecs from GenCollectorPolicy to GenCollectedHeap
Stefan Johansson
- RFR: 8198515: Extract SoftReferencePolicy code out of CollectorPolicy
Stefan Johansson
- RFR: 8198530: Move _gc_policy_counters from GenCollectorPolicy to GenCollectedHeap
Stefan Johansson
- RFR(XS): 8198510: Limit GC threads for small Java heap
Stefan Johansson
- RFR: 8198430 : Remove G1Allocator extension point
Stefan Johansson
- RFR: 8198431: Remove G1FullCollector extension point
Stefan Johansson
- RFR: 8198424: Remove G1AllocationContext
Stefan Johansson
- RFR(s): 8198268: Add time argument to ConcurrentGCTimer::register_gc_pause_start/_end
Stefan Karlsson
- RFR(xs): 8198270: Remove dangerous assert in HandleArea::oops_do()
Stefan Karlsson
- RFR(xs): 8198269: Allow GCCauseSetter to be used outside of safepoints
Stefan Karlsson
- RFR(s): 8198267: Allow GCId::current_raw() calls from non-NamedThreads
Stefan Karlsson
- RFR(s): 8198369: Clean up GCId and GCIdMark
Stefan Karlsson
- RFR(xs): 8198265: Make CollectorPolicy::satisfy_failed_metadata_allocation() virtual
Stefan Karlsson
- RFR: 8198373: Remove CollectorPolicy::is/as functions
Stefan Karlsson
- RFR: 8198507: Remove CollectorPolicy::create_rem_set
Stefan Karlsson
- RFR: 8198509: Move satisfy_failed_metadata_allocation out from CollectorPolicy
Stefan Karlsson
- RFR: 8198511: Move allocation functions from GenCollectorPolicy to GenCollectedHeap
Stefan Karlsson
- RFR: 8198515: Extract SoftReferencePolicy code out of CollectorPolicy
Stefan Karlsson
- RFR: 8198515: Extract SoftReferencePolicy code out of CollectorPolicy
Stefan Karlsson
- RFR: 8198525: Move _size_policy out of GenCollectorPolicy into GenCollectedHeap
Stefan Karlsson
- RFR: 8198528: Move GenerationSpecs from GenCollectorPolicy to GenCollectedHeap
Stefan Karlsson
- RFR: 8198530: Move _gc_policy_counters from GenCollectorPolicy to GenCollectedHeap
Stefan Karlsson
- RFR: 8198528: Move GenerationSpecs from GenCollectorPolicy to GenCollectedHeap
Stefan Karlsson
- RFR: 8198530: Move _gc_policy_counters from GenCollectorPolicy to GenCollectedHeap
Stefan Karlsson
- RFR: 8198528: Move GenerationSpecs from GenCollectorPolicy to GenCollectedHeap
Stefan Karlsson
- RFR: 8198373: Remove CollectorPolicy::is/as functions
Stefan Karlsson
- RFR: 8198511: Move allocation functions from GenCollectorPolicy to GenCollectedHeap
Stefan Karlsson
- RFR: 8198525: Move _size_policy out of GenCollectorPolicy into GenCollectedHeap
Stefan Karlsson
- RFR: 8198525: Move _size_policy out of GenCollectorPolicy into GenCollectedHeap
Stefan Karlsson
- RFR: 8198509: Move satisfy_failed_metadata_allocation out from CollectorPolicy
Stefan Karlsson
- RFR: 8198528: Move GenerationSpecs from GenCollectorPolicy to GenCollectedHeap
Stefan Karlsson
- Pushing the CollectorPolicy cleanup patch set
Stefan Karlsson
- [8u] RFR for backport of JDK-8148175: C1: G1 barriers don't preserve FP registers to jdk8u-dev
Vladimir Kozlov
- RFR(s): 8197992: Move the OopStorage::ParState type out of inline.hpp
Per Liden
- RFR(s): 8197993: Remove last use of JavaThread::flush_barrier_queues()
Per Liden
- RFR(s): 8197994: Move JavaThread::initialize_queues() logic to G1SATBCardTableLoggingModRefBS
Per Liden
- RFR(s): 8197994: Move JavaThread::initialize_queues() logic to G1SATBCardTableLoggingModRefBS
Per Liden
- RFR(s): 8197993: Remove last use of JavaThread::flush_barrier_queues()
Per Liden
- RFR(s): 8197993: Remove last use of JavaThread::flush_barrier_queues()
Per Liden
- RFR(s): 8197994: Move JavaThread::initialize_queues() logic to G1SATBCardTableLoggingModRefBS
Per Liden
- RFR(s): 8197994: Move JavaThread::initialize_queues() logic to G1SATBCardTableLoggingModRefBS
Per Liden
- RFR(s): 8197992: Move the OopStorage::ParState type out of inline.hpp
Per Liden
- RFR(s): 8197992: Move the OopStorage::ParState type out of inline.hpp
Per Liden
- RFR(xs): 8198265: Make CollectorPolicy::satisfy_failed_metadata_allocation() virtual
Per Liden
- RFR(s): 8198267: Allow GCId::current_raw() calls from non-NamedThreads
Per Liden
- RFR(s): 8198268: Add time argument to ConcurrentGCTimer::register_gc_pause_start/_end
Per Liden
- RFR(xs): 8198269: Allow GCCauseSetter to be used outside of safepoints
Per Liden
- RFR(xs): 8198270: Remove dangerous assert in HandleArea::oops_do()
Per Liden
- RFR(xs): 8198271: Make CollectedHeap::create_heap_space_summary() virtual
Per Liden
- RFR(xs): 8198271: Make CollectedHeap::create_heap_space_summary() virtual
Per Liden
- RFR(s): 8198268: Add time argument to ConcurrentGCTimer::register_gc_pause_start/_end
Per Liden
- RFR(s): 8198267: Allow GCId::current_raw() calls from non-NamedThreads
Per Liden
- RFR(s): 8198369: Clean up GCId and GCIdMark
Per Liden
- RFR(s): 8198268: Add time argument to ConcurrentGCTimer::register_gc_pause_start/_end
Per Liden
- RFR(xs): 8198269: Allow GCCauseSetter to be used outside of safepoints
Per Liden
- RFR(s): 8198267: Allow GCId::current_raw() calls from non-NamedThreads
Per Liden
- RFR(s): 8198369: Clean up GCId and GCIdMark
Per Liden
- RFR(s): 8198369: Clean up GCId and GCIdMark
Per Liden
- RFR(xs): 8198265: Make CollectorPolicy::satisfy_failed_metadata_allocation() virtual
Per Liden
- RFR(xs): 8198265: Make CollectorPolicy::satisfy_failed_metadata_allocation() virtual
Per Liden
- RFR(s): 8198267: Allow GCId::current_raw() calls from non-NamedThreads
Per Liden
- RFR: 8198507: Remove CollectorPolicy::create_rem_set
Per Liden
- RFR: 8198373: Remove CollectorPolicy::is/as functions
Per Liden
- RFR: 8198511: Move allocation functions from GenCollectorPolicy to GenCollectedHeap
Per Liden
- RFR: 8198515: Extract SoftReferencePolicy code out of CollectorPolicy
Per Liden
- RFR: 8198525: Move _size_policy out of GenCollectorPolicy into GenCollectedHeap
Per Liden
- RFR: 8198528: Move GenerationSpecs from GenCollectorPolicy to GenCollectedHeap
Per Liden
- RFR: 8198509: Move satisfy_failed_metadata_allocation out from CollectorPolicy
Per Liden
- RFR: 8198528: Move GenerationSpecs from GenCollectorPolicy to GenCollectedHeap
Per Liden
- RFR: 8198509: Move satisfy_failed_metadata_allocation out from CollectorPolicy
Per Liden
- RFR(s): 8198267: Allow GCId::current_raw() calls from non-NamedThreads
Per Lidén
- RFR(M): 8195103: Refactor ReduceInitialCardMarks to not assume all GCs use card marks
Erik Osterlund
- RFR: 8187577: JVM crash during gc doing concurrent marking
Poonam Parhar
- RFR: 8187577: JVM crash during gc doing concurrent marking
Poonam Parhar
- RFR: 8187577: JVM crash during gc doing concurrent marking
Poonam Parhar
- RFR: 8187577: JVM crash during gc doing concurrent marking
Poonam Parhar
- RFR: 8187577: JVM crash during gc doing concurrent marking
Poonam Parhar
- RFR (S): 8195115: G1 Old Gen MemoryPool CollectionUsage.used values don't reflect mixed GC results
Kirk Pepperdine
- RFR(M): 8195103: Refactor ReduceInitialCardMarks to not assume all GCs use card marks
Thomas Schatzl
- RFR (S): 8196602: Change HeapRegionClosure to comply to naming conventions
Thomas Schatzl
- RFR: 8187577: JVM crash during gc doing concurrent marking
Thomas Schatzl
- RFR (XS): 8196883: G1RemSet::refine_card_concurrently doesn't need to check for cards in collection set
Thomas Schatzl
- RFR (XS): 8196883: G1RemSet::refine_card_concurrently doesn't need to check for cards in collection set
Thomas Schatzl
- RFR (S): 8196602: Change HeapRegionClosure to comply to naming conventions
Thomas Schatzl
- RFR [Urgent] [Backout] JDK-8196602 Change HeapRegionClosure to comply to naming conventions
Thomas Schatzl
- RFR [Urgent] [Backout] JDK-8196602 Change HeapRegionClosure to comply to naming conventions
Thomas Schatzl
- RFR (S): 7127700: G1: Replace G1PLAB with PLAB
Thomas Schatzl
- RFR (S): 7127700: G1: Replace G1PLAB with PLAB
Thomas Schatzl
- RFR (S): 7127700: G1: Replace G1PLAB with PLAB
Thomas Schatzl
- [10] RFR: 8197968: [Backout] JDK-8196883 G1RemSet::refine_card_concurrently doesn't need to check for cards in collection set
Thomas Schatzl
- [10] RFR: 8197968: [Backout] JDK-8196883 G1RemSet::refine_card_concurrently doesn't need to check for cards in collection set
Thomas Schatzl
- RFR(s): 8197993: Remove last use of JavaThread::flush_barrier_queues()
Thomas Schatzl
- RFR(s): 8197994: Move JavaThread::initialize_queues() logic to G1SATBCardTableLoggingModRefBS
Thomas Schatzl
- RFR(s): 8197992: Move the OopStorage::ParState type out of inline.hpp
Thomas Schatzl
- RFR(xs): 8198271: Make CollectedHeap::create_heap_space_summary() virtual
Thomas Schatzl
- G1's parallel full GC significantly increases wasted space in Old regions
Thomas Schatzl
- RFR: 8198420: Remove unused extension point AllocationContextStats
Thomas Schatzl
- RFR: 8198507: Remove CollectorPolicy::create_rem_set
Thomas Schatzl
- RFR(XS): 8198510: Limit GC threads for small Java heap
Thomas Schatzl
- RFR(XS): 8198510: Limit GC threads for small Java heap
Thomas Schatzl
- RFR(XS): 8198510: Limit GC threads for small Java heap
Thomas Schatzl
- RFR: 8198430 : Remove G1Allocator extension point
Thomas Schatzl
- RFR: 8198424: Remove G1AllocationContext
Thomas Schatzl
- RFR: 8198431: Remove G1FullCollector extension point
Thomas Schatzl
- RFR [Urgent] [Backout] JDK-8196602 Change HeapRegionClosure to comply to naming conventions
Aleksey Shipilev
- PING: RFR: JDK-8153333: [REDO] STW phases at Concurrent GC should count in PerfCounter
Yasumasa Suenaga
- PING: RFR: JDK-8153333: [REDO] STW phases at Concurrent GC should count in PerfCounter
Yasumasa Suenaga
- PING: RFR: JDK-8153333: [REDO] STW phases at Concurrent GC should count in PerfCounter
Yasumasa Suenaga
- PING: RFR: JDK-8153333: [REDO] STW phases at Concurrent GC should count in PerfCounter
Yasumasa Suenaga
- PING: RFR: JDK-8153333: [REDO] STW phases at Concurrent GC should count in PerfCounter
Yasumasa Suenaga
- PING: RFR: JDK-8153333: [REDO] STW phases at Concurrent GC should count in PerfCounter
Yasumasa Suenaga
- PING: RFR: JDK-8153333: [REDO] STW phases at Concurrent GC should count in PerfCounter
Yasumasa Suenaga
- PING: RFR: JDK-8153333: [REDO] STW phases at Concurrent GC should count in PerfCounter
Yasumasa Suenaga
- RFR: 8187577: JVM crash during gc doing concurrent marking
coleen.phillimore at oracle.com
- RFR: 8187577: JVM crash during gc doing concurrent marking
coleen.phillimore at oracle.com
- [10] RFR: 8197968: [Backout] JDK-8196883 G1RemSet::refine_card_concurrently doesn't need to check for cards in collection set
jesper.wilhelmsson at oracle.com
- RFR (S): 8197844: JVMTI GetLoadedClasses should use the Access API
Erik Österlund
- RFR(s): 8197993: Remove last use of JavaThread::flush_barrier_queues()
Erik Österlund
- RFR(s): 8197993: Remove last use of JavaThread::flush_barrier_queues()
Erik Österlund
- RFR(s): 8197993: Remove last use of JavaThread::flush_barrier_queues()
Erik Österlund
- RFR(s): 8197994: Move JavaThread::initialize_queues() logic to G1SATBCardTableLoggingModRefBS
Erik Österlund
- RFR(s): 8197994: Move JavaThread::initialize_queues() logic to G1SATBCardTableLoggingModRefBS
Erik Österlund
- RFR(s): 8198369: Clean up GCId and GCIdMark
Erik Österlund
- RFR(xs): 8198265: Make CollectorPolicy::satisfy_failed_metadata_allocation() virtual
Erik Österlund
Last message date:
Wed Feb 28 07:26:00 UTC 2018
Archived on: Tue Oct 18 16:49:57 UTC 2022
This archive was generated by
Pipermail 0.09 (Mailman edition).