RFR: 8202642: Replace PAR_OOP_ITERATE with templates
Stefan Johansson
stefan.johansson at oracle.com
Mon May 7 08:28:13 UTC 2018
Hi Stefan,
On 2018-05-04 12:45, Stefan Karlsson wrote:
> Hi all,
>
> Please review this patch to replace the PAR_OOP_ITERATE macros with
> templates.
>
> http://cr.openjdk.java.net/~stefank/8202642/webrev.01/
Nice cleanup!
The change looks good and I understand that you just moved the code but
if you feel like it you could make a small change in space.inline.hpp:
383 HeapWord* t = mr.end();
Give 't' a better name, like 'end' or 'limit'.
---
I don't need a new webrev for this.
Thanks,
Stefan
> https://bugs.openjdk.java.net/browse/JDK-8202642
>
> The macros require use to stamp out GC-specific closures in shared code,
> while templates allows us to contain the GC-specific code in the
> GC-specific directories.
>
> This patch builds upon the patch in:
> http://mail.openjdk.java.net/pipermail/hotspot-gc-dev/2018-May/021968.html
>
> Thanks,
> StefanK
More information about the hotspot-gc-dev
mailing list