RFR: 8202863: Rename OopStorage inner collection classes

Kim Barrett kim.barrett at oracle.com
Thu May 17 20:33:51 UTC 2018


[Resending hotspot-dev too, so Coleen will see it, since she requested this change.]

Please review this simple renaming of some private inner classes of
OopStorage.  The renamings were suggested during the review of
JDK-8200557, but were deferred to a separate change to avoid adding
complexity to that review.  The following classes are being renamed:

BlockArray => ActiveArray
BlockList => AllocateList
BlockEntry => AllocateEntry

CR:
https://bugs.openjdk.java.net/browse/JDK-8202863

Webrev:
http://cr.openjdk.java.net/~kbarrett/8202863/open.00/

Testing:
Mach5 CI equivalent.




More information about the hotspot-gc-dev mailing list