RFR: 8213224: Move code related to GC threads calculation out of AdaptiveSizePolicy
Thomas Schatzl
thomas.schatzl at oracle.com
Thu Nov 22 12:16:22 UTC 2018
Hi,
On Mon, 2018-11-05 at 18:30 -0800, Man Cao wrote:
> Hi,
>
> Thanks for the review!
> I moved those 3 functions and created a new WorkerPolicy class as
> suggested.
> New webrev: https://cr.openjdk.java.net/~manc/8213224/webrev.01/
>
> There's a Sparc-specific heuristic for
> VM_Version::calc_parallel_worker_threads().
> I added a function
> Abstract_VM_Version::parallel_worker_threads_denominator() in order
> to keep this behavior and minimize relevant code in VM_Version class.
> I also changed "unsigned int" to "uint", for the functions from
> VM_Version.
>
> Now the change in workerManager.hpp is only trivial code movement and
> improving #include statements.
looks good to me.
Small nits about WorkerPolicy in the .hpp file (all optional, no need
for re-review from me):
- please add a newline after the static const GCWorkersPer...
- I would prefer to align the visibility modifiers with the "class"
keyword (ie. remove the single whitespace) with new classes.
- the first "private" may be omitted
Thanks,
Thomas
More information about the hotspot-gc-dev
mailing list