RFR(T): 8230192: Rename G1RedirtyCardsBufferList to G1BufferNodeList

Kim Barrett kim.barrett at oracle.com
Mon Aug 26 23:05:02 UTC 2019


Please review this trivial refactoring that renames a simple utility
struct and moves its definition to its own .hpp/.cpp files.  This will
permit the class to be used in other contexts that aren't related to
redirtying cards.  (I have a change in development that does just
that, and broke this piece out.)

CR:
https://bugs.openjdk.java.net/browse/JDK-8230192

Webrev:
http://cr.openjdk.java.net/~kbarrett/8230192/open.00/

Testing:
Local (linux-x64) hotspot:tier1.




More information about the hotspot-gc-dev mailing list