RFR: 8224660: Parallel GC: Use WorkGang (2: MarksFromRootsTask)

Thomas Schatzl thomas.schatzl at oracle.com
Wed Jul 3 09:35:49 UTC 2019


Hi,

On Tue, 2019-07-02 at 17:39 -0400, Kim Barrett wrote:
> Leo and I discussed my issues with the task claiming in the first
> version. We agreed to use SequentialSubTasksDone in this WorkGang
> conversion project, rather than gating that project on fixing various
> issues we have with the existing subtask claiming mechanisms. We'll
> just squint and ignore those issues for this project, and file some
> RFEs.
> 
> 
http://cr.openjdk.java.net/~lkorinth/workgang/1/_8224660-Parallel-GC-Use-WorkGang-2-MarksFromRootsTask/
> 
http://cr.openjdk.java.net/~lkorinth/workgang/1/_8224660-Parallel-GC-Use-WorkGang-2-MarksFromRootsTask-fixup-1/
> 
> These look good.
> 
> Just one minor naming change requested:
> 
> -------------------------------------------------------------------
> -----------
> src/hotspot/share/gc/parallel/psParallelCompact.cpp
> 2114 static void mark_from_roots_task(ParallelRootType::Value
> root_type, uint which) {
> 
> Instead of "which", please stay with "worker_id" or "worker_i", as
> used in the caller and more or less everywhere else.
> 

Please use "worker_id". Almost everything is using "worker_id" by now,
so let's avoid "worker_i" creeping back in.

Looks good. No need to re-review for this renaming.

Thanks,
  Thomas




More information about the hotspot-gc-dev mailing list