RFR (M): 8200545: Improve filter for enqueued deferred cards

Kim Barrett kim.barrett at oracle.com
Fri May 10 00:49:26 UTC 2019


> On May 6, 2019, at 5:51 AM, Thomas Schatzl <thomas.schatzl at oracle.com> wrote:
> http://cr.openjdk.java.net/~tschatzl/8200545/webrev.1_to_2/
> http://cr.openjdk.java.net/~tschatzl/8200545/webrev.2/
> 
> (Test: local compilation)
> 
> Thanks,
>  Thomas

==============================================================================
http://cr.openjdk.java.net/~tschatzl/8200545/webrev/

------------------------------------------------------------------------------
src/hotspot/share/gc/g1/g1InCSetState.hpp
  58   // The first two values are encoded in increasing generation order, which
  59   // allows us to use them as index into arrays; they also start at zero.

This part of the comment doesn't seem true.  Unless NotInCSet (value
== 0) is considered a "generation", but then there are 3 rather than
2.  The comment formerly talked about the "positive values" (e.g. the
values > 0).

------------------------------------------------------------------------------
src/hotspot/share/gc/g1/g1InCSetState.hpp
  67   static const in_cset_state_t NumGenInCSet =   3;    // Number of generations that can be in the collection set.

Again here, confusion about numbering.  There are only 3 generations
if NotInCSet is considered a "generation".

And places that use these as array indices generally "waste" an entry
for NotInCSet.  I thought there was a CR for that, but couldn't find it.

------------------------------------------------------------------------------
src/hotspot/share/gc/g1/g1InCSetState.hpp
  46 #ifdef SPARC
  47   uint32_t _needs_remset_update;
  48 #else
  49   uint8_t _needs_remset_update;
  50 #endif

Is it actually worth conditionalizing the type of this "bool" member?
Note that access via needs_remset_update() is going to be doing an
integral to bool conversion.

------------------------------------------------------------------------------

I kind of wish some of the changes to g1InCSetState.hpp had been done
separately.  Oh well...

------------------------------------------------------------------------------
src/hotspot/share/gc/g1/g1OopClosures.hpp
  65   G1ScanCardClosure(G1CollectedHeap* g1h,
  66                                   G1ParScanThreadState* pss) :

Fix indentation on line 66.

------------------------------------------------------------------------------
src/hotspot/share/gc/g1/heapRegionRemSet.hpp
 242 //      log_error(gc)("Region %u set complete", _hr->hrm_index());

Some left-over debugging code?

------------------------------------------------------------------------------
src/hotspot/share/gc/g1/g1CollectedHeap.cpp
2629 class RegisterHumongousWithInCSetFastTestClosure : public HeapRegionClosure {

This class seems misnamed now, since it is now doing stuff for all
regions (calls register_region_with_cset for non-humongous).  (Maybe
this is addressed in one of the other associated webrevs?)

Similarly, record_fast_reclaim_humongous_stats() seems somewhat
misnamed now, since the time value is for "register region".

------------------------------------------------------------------------------




More information about the hotspot-gc-dev mailing list