RFR (XXS): 8252086: G1: Remove g1_rs in G1CollectedHeap::initialize
Kim Barrett
kim.barrett at oracle.com
Fri Aug 21 16:29:47 UTC 2020
> On Aug 20, 2020, at 6:06 AM, Thomas Schatzl <thomas.schatzl at oracle.com> wrote:
>
> Hi,
>
> can I have reviews for this small change that removes an intermediate local variable from G1CollectedHeap::initialize?
>
> This makes it easier to follow that CollectedHeap::_reserved is the same as HeapRegionManager::reserved().
>
> CR:
> https://bugs.openjdk.java.net/browse/JDK-8252086
> Webrev:
> http://cr.openjdk.java.net/~tschatzl/8252086/webrev/
> Testing:
> local compilation, local jtreg gc/g1 directory
>
> Thanks,
> Thomas
Looks good.
More information about the hotspot-gc-dev
mailing list