RFR (M): 8238855: Move G1ConcurrentMark flag sanity checks to g1Arguments
Thomas Schatzl
thomas.schatzl at oracle.com
Tue Mar 24 12:56:21 UTC 2020
Hi,
On 20.03.20 22:46, Kim Barrett wrote:
>> On Mar 20, 2020, at 4:32 AM, Thomas Schatzl <thomas.schatzl at oracle.com> wrote:
>>
>> Hi all,
>>
>> can I have reviews for this change that moves (and deletes duplicate) flag checking from the G1ConcurrentMark class to the other G1 arguments processing?
>>
>> Adds a test that checks whether the invariants before/after are still kept.
>>
>> CR:
>> https://bugs.openjdk.java.net/browse/JDK-8238855
>> Webrev:
>> http://cr.openjdk.java.net/~tschatzl/8238855/webrev/
>> Testing:
>> hs-tier1-5 with new test
>>
>> Thanks,
>> Thomas
>
> Looks good.
>
> ------------------------------------------------------------------------------
> src/hotspot/share/gc/g1/g1Arguments.cpp
> 107 void G1Arguments::initialize_mark_stack_size() {
>
> Any particular reason for splitting this out into a separate function
> that has one caller? All the preceeding cases in the same caller are
> just directly inlined, so this looks kind of out of place.
>
> I don't object to this, but might actually prefer there to be more
> like it. That can wait for a followup.
>
> ------------------------------------------------------------------------------
Thanks for your review. The split makes the code of
G1Arguments::initialize() much easier to follow.
I will file a follow-up for further cleanup.
Thanks,
Thomas
More information about the hotspot-gc-dev
mailing list