RFR: 8250961: Move Universe::update_heap_info_at_gc to CollectedHeap
Stefan Karlsson
stefank at openjdk.java.net
Mon Sep 7 08:35:25 UTC 2020
On Sun, 6 Sep 2020 07:00:36 GMT, Aditya Mandaleeka <adityam at openjdk.org> wrote:
> This is a small refactoring that moves `update_heap_info_at_gc()` and related members to `CollectedHeap`. There should
> be no behavioral change.
> jdk/hotspot tier1 passed
>
> JBS: https://bugs.openjdk.java.net/browse/JDK-8250961
Now that the variables and functions have moved to CollectedHeap, I don't think we need the _heap_ infix anymore.
Maybe rename variables to be named:
_capacity_at_last_gc
_used_at_last_gc
Functions:
free_at_last_gc()
used_at_last_gc()
update_capacity_and_used_at_gc()
src/hotspot/share/gc/shared/collectedHeap.hpp line 524:
> 522: size_t get_heap_used_at_last_gc() { return _heap_used_at_last_gc; }
> 523: void update_heap_info_at_gc();
> 524:
Maybe move these to after unused(). Alternatively, move it near soft_ref_policy(), since this is currently only used by
soft ref handling.
-------------
PR: https://git.openjdk.java.net/jdk/pull/27
More information about the hotspot-gc-dev
mailing list