RFR: 8252888: Simplify G1MMUTracker class hierarchy
Kim Barrett
kim.barrett at oracle.com
Sat Sep 19 04:49:55 UTC 2020
> On Sep 18, 2020, at 2:47 PM, Albert Mingkun Yang <ayang at openjdk.java.net> wrote:
>
> On Wed, 16 Sep 2020 23:19:56 GMT, John Tortugo <github.com+2249648+JohnTortugo at openjdk.org> wrote:
>
>> Relates to: https://bugs.openjdk.java.net/browse/JDK-8252888
>> Tested on: x86_64 - Linux - tier1
>> Need sponsor: yes
>>
>> Merge `G1MMUTracker` and `G1MMUTrackerQueue` into a single class and make method members non virtual.
>
> I think it's better to use `G1MMUTracker` as the type name and mention its queue implementation in the comments,
> instead of including "Queue" in its name.
+1
G1MMUTracker is what it is. That there is a queue involved is an implementation detail.
>
> -------------
>
> PR: https://git.openjdk.java.net/jdk/pull/214
More information about the hotspot-gc-dev
mailing list