RFR: 8265119: G1: update_remset_before_rebuild mixes liveness in words with liveness in bytes
Thomas Schatzl
tschatzl at openjdk.java.net
Thu Apr 15 10:17:38 UTC 2021
On Thu, 15 Apr 2021 09:29:07 GMT, Ivan Walulya <iwalulya at openjdk.org> wrote:
> Hi all,
>
> Please review this change to rename ConcurrentMark::liveness() to live_words() making it clear that this represents the number of live words between bottom and nTAMS. Adding ConcurrentMark::live_bytes() to return the same value in bytes. Additionally, I add a test for G1MixedGCLiveThresholdPercent flag.
>
> Testing: tier 1-5.
Lgtm apart from the few nits.
src/hotspot/share/gc/g1/g1ConcurrentMark.hpp line 465:
> 463: // live words between bottom and nTAMS.
> 464: size_t live_words(uint region) const { return _region_mark_stats[region]._live_words; }
> 465:
Something like "same as above but returns bytes" would be nice.
test/hotspot/jtreg/gc/g1/TestMixedGCLiveThreshold.java line 68:
> 66: Asserts.assertEquals(regionsSelected, expectedRebuild,
> 67: (expectedRebuild ?
> 68: "No Regions selected for rebuild. G1MixedGCLiveThresholdPercent="+ liveThresholdPercent +
Spaces before the operator at the end. There is another one below too.
test/hotspot/jtreg/gc/g1/TestMixedGCLiveThreshold.java line 88:
> 86: "-Xmx10M"});
> 87:
> 88: basicOpts.add("-XX:G1MixedGCLiveThresholdPercent="+percent);
Whitespace before and after the `+`.
-------------
Marked as reviewed by tschatzl (Reviewer).
PR: https://git.openjdk.java.net/jdk/pull/3511
More information about the hotspot-gc-dev
mailing list