RFR: 8231672: Simplify the reference processing parallelization framework [v4]

Leo Korinth lkorinth at openjdk.java.net
Fri Apr 16 14:37:39 UTC 2021


On Thu, 11 Mar 2021 10:18:27 GMT, Leo Korinth <lkorinth at openjdk.org> wrote:

>> With the change of parallel gc to use the same workgang implementation that other gcs uses, it is possible to remove the abstraction used to hide different worker thread management implementations (TaskExecutor).
>> 
>> At the same time as removing the TaskExecutor, also remove part of the special casing (mostly code duplication), for single threaded execution. 
>> 
>> I consider the new method `prepare_run_task` that modifies the state of the context a step backwards from what was. However, I think removing the Executor with its proxy-tasks and removing separate code paths for serial execution makes the change worth this step back. We also removes ~270 lines of code.
>> 
>> Some comments:
>> 1) I use references in some places where they can replace pointers. I could go much further here, but I did not want to bloat the pull request, maybe later change all closures to be references as well? Should I create enhancements for this?
>> 
>> 2) I added an enum class ThreadModel instead of using a boolean, this could also be used in many more places. I dislike sending lots of bools with a comment like `true /* _is_mt */`. It also adds type safety if a method takes many bools. However, with this limited change, and not many hard-coded bools, it feels a bit overkill and I am willing to remove the enum, what do you think?
>> 
>> Testing:
>> hotspot_gc  and tier 1-3 has passed earlier versions before minor cleanups. I intend to re-run tests after review changes.
>
> Leo Korinth has updated the pull request incrementally with one additional commit since the last revision:
> 
>   remove maybe prefix, change in one place to nullable

Hi, and sorry for the long silence from me.

I got feedback from Albert on improving the structure of this change and to use proxy classes instead of ClosureContexts. This will solve the problem with heap allocated closures and also improve readability IMO.

The change is big, so I will not push it to this review thread before you agree with that it is the right way to go, but you can see the change here: https://github.com/lkorinth/jdk/commit/5cdddacd037c7ea4baf648262b9637540c5ec3e4

If you agree with me, I will push that change to this review.

-------------

PR: https://git.openjdk.java.net/jdk/pull/2782



More information about the hotspot-gc-dev mailing list