RFR: 8278351: Add function to retrieve worker_id from any context [v3]

Per Liden pliden at openjdk.java.net
Mon Dec 13 11:06:43 UTC 2021


> The `worker_id` argument passed to `WorkerTask::work(uint worker_id)` is sometimes needed in contexts where it today can't be easily accessed, mainly because it's not feasible to pass this argument through many layers of semi-unrelated code. To solve this, I propose that we make the current `worker_id` accessible though a static function `WorkerThread::worker_id()`.
> 
> By doing this, we also pave the way for ZGC to remove its `ZTask` and `ZThread`, which are helper class to make the `worker_id` easily accessible in any context.
> 
> At the same time I propose that we remove `WorkerThread::_id`. This id identifies the actual worker thread. There is currently only one user of `WorkerThread::_id`, the `ReferenceProcessor`. However, we should use `WorkerThread::worker_id()` here instead. The only reason it doesn't use `worker_id` today is that it's not easily accessible in that context (the discover path).
> 
> Testing: Passed Tier1-3

Per Liden has updated the pull request incrementally with two additional commits since the last revision:

 - Rename 'which' to 'name_suffix'
 - Add 'on_create_worker()' hook

-------------

Changes:
  - all: https://git.openjdk.java.net/jdk/pull/6747/files
  - new: https://git.openjdk.java.net/jdk/pull/6747/files/f669780d..67d3299c

Webrevs:
 - full: https://webrevs.openjdk.java.net/?repo=jdk&pr=6747&range=02
 - incr: https://webrevs.openjdk.java.net/?repo=jdk&pr=6747&range=01-02

  Stats: 13 lines in 4 files changed: 4 ins; 2 del; 7 mod
  Patch: https://git.openjdk.java.net/jdk/pull/6747.diff
  Fetch: git fetch https://git.openjdk.java.net/jdk pull/6747/head:pull/6747

PR: https://git.openjdk.java.net/jdk/pull/6747



More information about the hotspot-gc-dev mailing list