RFR: 8278351: Add function to retrieve worker_id from any context [v3]

Erik Österlund eosterlund at openjdk.java.net
Mon Dec 13 12:44:07 UTC 2021


On Mon, 13 Dec 2021 11:06:43 GMT, Per Liden <pliden at openjdk.org> wrote:

>> The `worker_id` argument passed to `WorkerTask::work(uint worker_id)` is sometimes needed in contexts where it today can't be easily accessed, mainly because it's not feasible to pass this argument through many layers of semi-unrelated code. To solve this, I propose that we make the current `worker_id` accessible though a static function `WorkerThread::worker_id()`.
>> 
>> By doing this, we also pave the way for ZGC to remove its `ZTask` and `ZThread`, which are helper class to make the `worker_id` easily accessible in any context.
>> 
>> At the same time I propose that we remove `WorkerThread::_id`. This id identifies the actual worker thread. There is currently only one user of `WorkerThread::_id`, the `ReferenceProcessor`. However, we should use `WorkerThread::worker_id()` here instead. The only reason it doesn't use `worker_id` today is that it's not easily accessible in that context (the discover path).
>> 
>> Testing: Passed Tier1-3
>
> Per Liden has updated the pull request incrementally with two additional commits since the last revision:
> 
>  - Rename 'which' to 'name_suffix'
>  - Add 'on_create_worker()' hook

Marked as reviewed by eosterlund (Reviewer).

-------------

PR: https://git.openjdk.java.net/jdk/pull/6747



More information about the hotspot-gc-dev mailing list