RFR: 8261230: GC tracing of page sizes are wrong in a few places [v2]
Albert Mingkun Yang
ayang at openjdk.java.net
Fri Feb 12 12:27:45 UTC 2021
On Thu, 11 Feb 2021 17:29:34 GMT, Stefan Johansson <sjohanss at openjdk.org> wrote:
>> Yes, and also for `checkLargePagesEnabled`. It's not obvious to me why we parse the output in those two places, one looking for the failure mode, and the other looking for the success mode. That's why I asked for an sample of the "expected" log output.
>
> I think the check if large pages are enable is pretty straight forward. We should never expect large page sizes in the output unless large pages are enabled. I do however agree that this check is a bit clunky. Would it help to extract it to a separate function? Something like `largePagesAllocationFailure(pattern)`, I could also change the name of the function above to just be `largePagesEnabled()` then the code reads even better?
I overlooked the fact that `largePagesAllocationFailure` is pattern/data structure specific. I am happy with the current patch. Thank you.
-------------
PR: https://git.openjdk.java.net/jdk/pull/2486
More information about the hotspot-gc-dev
mailing list